Saturday, June 16, 2007

Ubuntu Microphone Problems and Solutions

I had a rough time with my microphone last week on my Ubuntu fiesty (7.04).I burned my weekend hours to google it and the story had a happy ending.To my surprise,most of the good links buried under some useless stuff.So,I decided to post those links which helped me and hope would help people who are in need.

Here is the solution that solved my problem.Open your terminal and just copy and paste the following code(got
from Ubuntu support site) to get the latest ALSA drivers which can fix.

wget
ftp://ftp.alsa-project.org/pub/driver
/alsa-driver-1.0.14.tar.bz2
tar -xjf alsa-driver-1.0.14.tar.bz2
cd alsa-driver-1.0.14
./configure
sudo make
sudo make install

But before trying above trick you can try one more.Double click on the volume icon on the panel.Then Edit>Preferences.Then make sure you have selected Microphone,Mic boost,Capture.Once you do this you can find new capture tab in the volume control panel.Here, make sure nothing is muted(no red x on microphone icon).In options tab make sure you selected Microphone as input source.

Third is editing esd.conf as follows.Type the following code in the terminal.

sudo gedit /etc/esound/esd.conf

Then edit the file like this.It worked for some people and I got this ubuntu forums.

[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 1
spawn_wait_ms=100
# default options are used in spawned and non-spawned mode
default_options=

If none of them seems to work , you can visit ubuntu forums where people discussed some other ways of activating microphone.Hope it works.

10 comments:

wigglematch said...

Found a solution which worked for me on http://ubuntuforums.org/showthread.php?p=2839571

The magic command was: sudo /etc/init.d/alsa-utils restart

Sravan Kundojjala said...

good to know that and thanks for updating.

Sravan Kundojjala said...

A comprehensive guide to ubuntu sound related problems...try this if all the above fails....

http://ubuntuforums.org/showthread.php?t=205449

If you have sound problem with YouTube videos(common problem in ubuntu 7.04) download Flash 9 here
http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash

Riccardo said...

The magic command ( sudo etc/init.d/alsa-utils restart ) doesn't work for me, the latest driver works!
Thank you

Xin said...

hey, thanks for posting! it solved my Mic issue.

It's really confusing how you have to select the different inputs. I'm glad you explained it.

guchi guchi said...

a thousand thank yous for your guide. I tried everything all night and only this seemed to work.

I now have audio capture for my gutsy and its only 1:22 in the morning.

Thank you very much

Ken D said...

Hey Thanks a Lot!!!!

Amit sethi said...

thanks .. works well

Steffen said...

after following you guide i suddenly lost all sound. when i enter ubuntu there is a red cross over the sound. and i get the famous error: no volume control GStreamer... what shall i do ?

Silicon Sillu said...

Hi, I used the method mentioned here to activate my non-working Mic. but alas, the whole sound has gone! Sound is not working now!

I did "make uninstall" and undid the changes made in esd.conf

But still the sound is not back! Any idea?!